Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

Version de maintenance 1.5.1 de JRuby
. Migration recommandée pour les utilisateurs de Google AppEngine et de l'intégration avec Java

Le , par Ricky81

0PARTAGES

0  0 
09/06/2010

Citation Envoyé par Ricky81 Voir le message
Bonjour,

La version de maintenance 1.5.1 est disponible et la migration est recommandée pour les utilisateurs de Google AppEngine et de l'intégration avec Java.

Release notes
Télécharger
19/05/2010

Bonjour,

La semaine dernière est sortie la version 1.5 de JRuby, version à laquelle ont contribué pas moins de 30 développeurs Open Source.

Parmi les 4 core developpers, 3 font partie de la société Engine Yard.

Les avancées principales pour cette version sont :
  • Meilleure intégration avec les librairies Java (gestion mémoire et CPU plus efficace)
  • Amélioration de la compatibilité avec Ruby (Ruby 1.8.7)
  • Amélioration du support pour Windows (les nombreux problèmes qui rendait son utilisation sous Windows compliquée ont été traités)


Pour les développeurs Java, il est également à noter de meilleures intégration avec Ant et Maven.

Qui utilise régulièrement JRuby, et dans quel cadre ?

Source EngineYards : Engine Yard Applauds Release of JRuby 1.5
Téléchargez la dernière version
Highlights
Voir également :
Débat sur l'intérêt de JRuby
L'équipe JRuby quitte Sun suite au rachat par Oracle, et rejoint la société Engine Yard spécialisée en Rails

Une erreur dans cette actualité ? Signalez-le nous !

Avatar de Ricky81
Expert éminent sénior https://www.developpez.com
Le 09/06/2010 à 7:43
Bonjour,

La version de maintenance 1.5.1 est disponible et la migration est recommandée pour les utilisateurs de Google AppEngine et de l'intégration avec Java.

Release notes
Télécharger
0  0